Shopify App

So my wife and I moved in April, and I finally finished setting up my office and setup my Tidbyt again. Was excited when I went through the list of new apps to try that there was now a Shopify app. My wife and I run a retail store and also have a Shopify store. But I can’t for the life of me get it to authenticate.

I’m a developer and so I already had an API token for my own development. I used that token and it tells me “UNABLE TO AUTH”. So I created a new token, and get the same error.

Anyone successfully got the app working?

Not the author, but looked at the Shopify App’s code, and the “UNABLE TO AUTH” message only displays on a 401 response from the Shopify API. In Shopify’s API documentation this is more verbosely, “The necessary authentication credentials are not present in the request or are incorrect.”

At first glance the API request generated by the code appears valid with current Shopify API versioning. Is it possible there is a copy/paste error with your API key or store name? I assume the store name must be an exact match as well. If that all checks out, and the code is indeed bug free, perhaps there is an issue with the API access scope for the particular API key you’re using?

Per the Shopify App’s readme: https://github.com/tidbyt/community/blob/main/apps/shopifychart/README.md

“Note that you must generate a Shopify custom app with read_orders access in order to connect to the Shopify API.”

My guess is that’s likely the issue!

Hey there! Thanks for the reply. Totally forgot that the code was probably on GitHub for me to look at! I’ll look at the code and see what I can work out. I have my own node app that I use to sync data from Shopify to a local database and what’s weird is that for me to work with the Shopify API I need a token and a secret. This app only seems to be looking for a token, so that’s why I was wondering if someone had successfully got it to work.

Anyway, thanks for the reply, I’ll look at the code.

Still looking into the code… but I did realize one mistake I made… in the API I use in node it requires an API key and secret. So I was using the API key for this… and of course realized I need to use the API access token instead. Still not working when I made that change, but wanted to update this here in case anyone reads my reply above and thinks the answer is I wasn’t using the access token.

Heyo, I wanted to elaborate on one thing from my previous post if you haven’t found a solution yet.

In the app settings, the store name needs to be exactly as it is in the Shopify URL. It is passed as-is directly into the URL of the API request.

If it’s not exact I expect you’d be getting that “UNABLE TO AUTH” error as it’d appear that you’re trying to request access to data from another store not tied to your API access token.

For example, if you put something like, “Warwick Price” with a space, and your internal Shopify URL is https://warwickprice.myshopify.com/, then it’s not going to work. The store name in the settings would have to be “warwickprice”.

Hello!

Any luck getting this app to work? I have created an api-token with a custom app with the read_orrders access and ensured that the store name is exactly reproduced in the tidbyts app settings, but to no avail. Any one figure this out yet?

Sadly, no. And I have so many other things I’m working on this was more of a nice to have and so haven’t been able to get back to digging in. But like you, I did double/triple check that the token and store name were 100% correct with no luck.

Yeah I’m having the same issue unfortunately.

Have you confirmed the app was installed into the store?

You need to make sure you are using the Admin API access token that you get when you install the app. Do not use the API key and Secret Key

I can personally vouch and say that yes, the app is installed and I am using the Admin API access token (the one that only gets shown once). No matter what I do, the app refuses to load.

I’ve tried everything I can to troubleshoot this from my end. Gave it wide open permissions through the API, messed with store name, uninstalled and started fresh, no matter what it just comes back with Unable To Auth.