Setup fails after “CONNECTING…” when trying to link Tidbyt to Wifi

I posted this here but haven’t received a response for a week, so I thought I’d make it a standalone thread.

On initial setup, I get “can’t connect” then it goes back to bluetooth.

I’ve tried both my guest network and my main network. No dice on either. Tidbyt has never connected and I can’t get it set up at all.

Here’s my log:

I (33378) tidbyt: free memory - exec: 68976, internal: 71559, DMA: 62695, malloc: 4157423
I (33378) tidbyt: memory low watermark - exec: 61136, internal: 62263, DMA: 53411, malloc: 4126075
I (44138) tidbyt/sprites: Loading sprite 2 from asset (5614 bytes)
I (44138) tidbyt/ble: connected to 53:c2:fa:b6:c1:f4
I (44148) tidbyt/ble: Sent event: CONFIGURE
I (44148) tidbyt/configure: Waiting for config via Bluetooth
I (63388) tidbyt: free memory - exec: 65532, internal: 66987, DMA: 58123, malloc: 4140043
I (63388) tidbyt: memory low watermark - exec: 61136, internal: 62263, DMA: 53411, malloc: 4113751
I (63948) tidbyt/configure: Received configuration attributes via Bluetooth
I (65598) tidbyt: Entering state CONNECT (3).
I (65598) tidbyt/ble: Sent event: INIT_CONNECT
I (65598) tidbyt/connect: Configuring wifi network: (My SSID censored to post publicly)
I (65608) tidbyt: free memory - exec: 64836, internal: 66635, DMA: 57771, malloc: 4139419
I (65628) tidbyt: memory low watermark - exec: 61136, internal: 62263, DMA: 53411, malloc: 4113751
I (65658) tidbyt/cloud: using device status topic: /devices/randomly-famed-sharp-lion-82a/state
I (65658) tidbyt/cloud: using heartbeat topic: /devices/randomly-famed-sharp-lion-82a/events/heartbeat
I (65668) tidbyt/crypto: Parsed private key with bit length 256.
I (65668) tidbyt/crypto: Using ECDSA with public key:
-----BEGIN PUBLIC KEY-----
MFkwEwYHKoZIzj0CAQYIKoZIzj0DAQcDQgAEX14Tw9BfKesHwPCiDfb26TPSe4mB
ZR6JY0DFLuDMg3l/9ciinbNpiqjSDPrymjUZBVsNLJQnTGYM0uOyuIXAtw==
-----END PUBLIC KEY-----

I (65698) tidbyt/sprites: Loading sprite 3 from asset (29868 bytes)
I (65708) tidbyt/ble: Sent event: WIFI_CONNECT
I (65978) wifi:new:<3,1>, old:<1,0>, ap:<255,255>, sta:<3,1>, prof:1
I (65978) wifi:state: init -> auth (b0)
I (65988) wifi:state: auth -> assoc (0)
I (65998) wifi:state: assoc -> run (10)
I (68108) wifi:state: run -> init (fc0)
I (68108) wifi:new:<3,0>, old:<3,1>, ap:<255,255>, sta:<3,1>, prof:1
I (68108) wifi:new:<3,0>, old:<3,0>, ap:<255,255>, sta:<3,1>, prof:1
I (68108) tidbyt/wifi: SYSTEM_EVENT_STA_DISCONNECTED reason code: 15
I (68118) tidbyt/wifi: Unhandled wifi disconnect event 15
W (68708) tidbyt/connect: Wi-fi disconnected with reason 15, counting as auth failure
W (69718) tidbyt/connect: Wi-fi disconnected with reason 15, counting as auth failure
I (70198) tidbyt/wifi: SYSTEM_EVENT_STA_DISCONNECTED reason code: 205
I (70208) tidbyt/wifi: Unhandled wifi disconnect event 205
I (70218) wifi:new:<3,1>, old:<3,0>, ap:<255,255>, sta:<3,1>, prof:1
I (70218) wifi:state: init -> auth (b0)
I (70228) wifi:state: auth -> assoc (0)
I (70238) wifi:state: assoc -> run (10)
W (70718) tidbyt/connect: Wi-fi disconnected with reason 205
W (71718) tidbyt/connect: Wi-fi disconnected with reason 205
I (72348) wifi:state: run -> init (fc0)
I (72348) wifi:new:<3,0>, old:<3,1>, ap:<255,255>, sta:<3,1>, prof:1
I (72348) wifi:new:<3,0>, old:<3,0>, ap:<255,255>, sta:<3,1>, prof:1
I (72358) tidbyt/wifi: SYSTEM_EVENT_STA_DISCONNECTED reason code: 15
I (72358) tidbyt/wifi: Unhandled wifi disconnect event 15
W (72718) tidbyt/connect: Wi-fi disconnected with reason 15, counting as auth failure
W (73728) tidbyt/connect: Wi-fi disconnected with reason 15, counting as auth failure
I (74438) tidbyt/wifi: SYSTEM_EVENT_STA_DISCONNECTED reason code: 205
I (74438) tidbyt/wifi: Unhandled wifi disconnect event 205
I (74458) wifi:new:<3,1>, old:<3,0>, ap:<255,255>, sta:<3,1>, prof:1
I (74458) wifi:state: init -> auth (b0)
I (74468) wifi:state: auth -> assoc (0)
I (74478) wifi:state: assoc -> run (10)
W (74748) tidbyt/connect: Wi-fi disconnected with reason 205
W (75748) tidbyt/connect: Wi-fi disconnected with reason 205
I (76588) wifi:state: run -> init (fc0)
I (76588) wifi:new:<3,0>, old:<3,1>, ap:<255,255>, sta:<3,1>, prof:1
I (76588) wifi:new:<3,0>, old:<3,0>, ap:<255,255>, sta:<3,1>, prof:1
I (76598) tidbyt/wifi: SYSTEM_EVENT_STA_DISCONNECTED reason code: 15
I (76598) tidbyt/wifi: Unhandled wifi disconnect event 15
W (76748) tidbyt/connect: Wi-fi disconnected with reason 15, counting as auth failure
W (77748) tidbyt/connect: Wi-fi disconnected with reason 15, counting as auth failure
E (77758) tidbyt/connect: Multiple wi-fi auth failures
E (77758) tidbyt/connect: switching back to CONFIGURE since a permanent failure occurred
I (77768) tidbyt/ble: Sent event: ERROR_WIFI
I (77788) tidbyt: Entering state CONFIGURE (2).
I (77788) tidbyt/ble: Sent event: CONFIGURE
I (77788) tidbyt: free memory - exec: 55332, internal: 57059, DMA: 48195, malloc: 4080983
I (77798) tidbyt: memory low watermark - exec: 46380, internal: 47507, DMA: 38655, malloc: 4048699
I (77808) tidbyt/sprites: Loading sprite 1 from asset (210 bytes)
I (77808) tidbyt/configure: Wait for Bluetooth connection
I (77818) tidbyt/sprites: Loading sprite 2 from asset (5614 bytes)
I (77828) tidbyt/ble: advertising start successfully
I (77828) tidbyt/configure: Waiting for config via Bluetooth

Hi Kevin, apologies for missing your message earlier.

Looking at this log, it looks like the security handshake between the Tidbyt and the router is failing. I know you’ve probably checked this, but could you triple-check that the password is correct, with no extra spaces at the end or anything like that?

Also, would you mind sharing the make and model of your router?

Password is definitely correct for both networks I’ve tried.

It’s one of these: Orbi RBK353 - AX1800 WiFi Mesh System | NETGEAR