Pixlet on MacOS with M1 chip


I’m not able to install the pixlet cli on my Mac with an M1 chip, using homebrew i get the following error

➜  tidbyt brew install tidbyt/tidbyt/pixlet
==> Tapping tidbyt/tidbyt
Cloning into '/opt/homebrew/Library/Taps/tidbyt/homebrew-tidbyt'...
remote: Enumerating objects: 76, done.
remote: Counting objects: 100% (76/76), done.
remote: Compressing objects: 100% (75/75), done.
remote: Total 76 (delta 47), reused 0 (delta 0), pack-reused 0
Receiving objects: 100% (76/76), 10.64 KiB | 5.32 MiB/s, done.
Resolving deltas: 100% (47/47), done.
Error: Invalid formula: /opt/homebrew/Library/Taps/tidbyt/homebrew-tidbyt/pixlet.rb
formulae require at least a URL
Error: Cannot tap tidbyt/tidbyt: invalid syntax in tap!

I downloaded the binary directly and tried to use it but it didn’t work neither.

Any help is appreciated it

Hi @boredabdel,

So sorry for the issues. We were able to add support for Apple M1 in our latest release of Pixlet version v0.8.4 . Please try the brew install again and let us know if you have any additional issues!

1 Like

Thanks mark. I managed to compile from source 2 days ago. But i can confirm brew install works now


1 Like