'pixlet login' on headless server

Does anyone know if we can pixlet login on a headless server? I’m SSH’d into a server that I’d like to use to push a local *.webp image, but I need to login to pixlet first. login.tidbyt.com wants to redirect to localhost, but that’s not the server that generates the link. When I curl the localhost:8085… link, pixlet throws a getting auth token: state mismatch in 3-legged-OAuth flow error.

Any ideas? Thanks!

maybe just use the api key for the tidbyt instead of login.

How does one use the API key with pixlet? I’m getting the same errors as OP. Were you able to figure it out @byrleyar?

edit: I ended up doing some SSH port forwarding to make this work.

ssh -L8085:localhost:8085 [email protected]

Open the authentication URL in your browser and when it tries to run the localhost URL, it will succeed.

I’m using an LXC container in Proxmox with Debian.

I also ended building pixlet from source instead of using the binary like I was trying at first. I saw someone mention that the binary had issues authenticating but the built version did not.

You can get your device id and api key from the tidbyt phone app. Use that directly in your pixlet push call and you don’t have to deal with any login shenannigans.

Just click on the settings icon (top right corner of the screen) and open the “General” tab.

Another option is to run pixlet login --json on a different computer (not the headless server). It will go through the login process and then print the token on the console.