Pixel push results in 401 - invalid auth token: invalid character 'Õ'


I tried pushing via pixlet to the device for the first time, usuccessfully. I’m seeing 401 responses.


pixlet push --api-token BIG_KEY ODD_DEVICE_NAME bitcoin.webp
Tidbyt API returned status 401 Unauthorized
{"code":16, "message":"invalid auth token: invalid character 'Õ' looking for beginning of value", "details":[]}

Status (https://status.tidbyt.com) looks OK.


Hey @chrisdangelo, welcome to the community!

What kind of development environment are you trying this in, as far as OS/terminal and where you’re copying your API token from before pasting?

Assuming that the token (and device id) themselves are correct, I wonder if there’s something to the way it’s being copied/pasted that the character encodings of the text itself is wrong somehow? I believe the API looks for UTF-8, but an actual developer might be able to answer that better.

That could explain why the API is seeing a seemingly arbitrary character?

EDIT: You can also try doing the push from here as well (Push to a device | Tidbyt API), you just have to encode the image as a base-64 string to include. Maybe during this process you’ll be able to troubleshoot your issue or gather a helpful insight.

Thank you. Good idea.

Yes it looks like some copy paste error. I retried…

  1. Using the iOS app to “Copy to clipboard”, then
  2. pasted it into a text editor on my Mac, then
  3. Invoking pixlet copy pasted from the text editor, and

It worked! Have a good day. Thanks.