Night Mode causing issues

Hey there!

I’ve suddenly found my Tidbyt stuck on the logo / stuck on connecting, then (sometimes) getting to the logo and staying there when it tries to come out of Night Mode.

I also had it where it did actually come out of Night Mode, but apps were doing weird things:

  • Stocks and Clock By Henry just wouldn’t show (Stocks has a weekday only schedule on it, the other one doesn’t)
  • Weather was stuck showing the three day forecast for the day it came out of Night Mode (I didn’t actually notice for two days because it’s been raining. lol)
  • Jokes JokeAPI was stuck on the joke of the day from the day it came out of Night Mode.

When I looked at the app, all 4 of those apps were correct on my phone. But I couldn’t get the Tidbyt to update without power cycling.

Anyway, here are the details I can think of worth mentioning:

I’ve had my Tidbyt since the kickstarter and I’ve never had any direct problems with the unit itself before. I moved and got a new internet provider (fiber! woo!) and new router hardware. Eero 6Pro. I had the same kind of Eeros at my last place/provider and everything worked just fine. This time I had to buy new hardware, so I went with what I thought I knew already worked. I have updated them to eeroOS v7.0.0-1134. My unit is roughly equidistant from the two eeros (~15’) and the connection appears to be 1) good and 2) not confused about which one it’s connected to.

I moved my Tidbyt in the original packaging and it does not appear to be damaged.

It has not worked correctly since connecting it to this network. I gave the new one the same name/password so the Tidbyt automatically connected on its own.

I would notice in the morning that my unit would either be stuck on connecting or be on the Tidbyt logo forever. If I power cycled it, it would work perfectly fine until the next day. Finally I got fed up and Factory Reset it and re-added everything by hand (and added a couple new apps). It happened again. I noticed it was always messed up in the morning, so I turned off Night Mode and power cycled it. It worked fine for a few days, so I trying turning night mode back on. It didn’t actually go into Night Mode that night, so I power cycled it the following morning. It went into Night Mode and came back out (I thought). It seemed to be working until I noticed two days later that there was weird behavior. So I turned off Night Mode and power cycled it and it seems to be working so far.

I also have ‘Dim at sunset’ turned on, Peak brightness set to 20 and App cycle speed on Normal.

I suspect I can get the same effect as Night Mode by just scheduling all my apps individually, but I haven’t tried that yet (mostly because that’s a huge pain in the butt and I don’t want to). I really like the Night Mode setting. I’d like to be able to use it.

Does anybody have any suggestions or ideas? I’m pretty much stumped at this point.

1 Like

Interesting update:

So I tried just scheduling all but two of my previously unscheduled apps individually: on at 7am, off at 11pm.
I left Clock By Henry and Starfield on 24-7, 7 days a week.

I encountered the same problem: when I came out in the morning after having scheduled everything to turn off, my unit was in that same infinite TIDBYT logo loop.

The only thing I can think of is that maybe it has something to do with the amount of network traffic and when the traffic dips too low it gets confused and thinks it’s disconnected or in some weird state.