Is Pixlet only available on MacOS and Linux?

Ok using WSL method I’m stuck as per AmillionAir’s guide on step 9 to render and server for hello world. I’ve also done the “libwebpdemux.so.2” step but I was not experiencing this issue. Plus I’m on v0.9
I keep getting:
“-bash: ./pixlet: cannot execute binary file: Exec format error”
Maybe I’ve written the serve command incorrectly or missing another essential installation.
Any ideas please?

I think i forgot to add this step into my guide initally try running that. You might have also messed something up by running the libwebpdemux.so.2 step if it wasnt needed???

Thanks Amillion!
Yes I ran that sudo chmod +x /usr/bin/pixlet command as per your step 8.
Also I only ran “libwebpdemux.so.2” when I noticed this error, so same result before and after.

PS: My Ubuntu machine is running the pixlet serve with no issues

I had to to a fresh install of windows last night as my WSL permissions got all messed up let me see if i run into the same problem when re installing everything.

@andrewf13 I HAVE THE SOLUTION

sudo apt-get install -y libwebp-dev

run this and it should install all the libraries you need!! i got mine working after that

Thanks already did that, issue persists.
I had a quick look what this error means “cannot execute binary file”, it means the processor type does not match. I had downloaded “arm” version but I’m running an Intel processor so I should’ve downloaded the “amd64” version. Perhaps need a note under step 4 to highlight must download “amd64” version and not “arm”…I don’t think many people would be running arm CPUs on Windows.
My bad, sorry and thanks for your help here!

To run star files located in my home folder, what would be the command please?
Keep getting errors like this:

Note: running files from Github examples folder https://github.com/tidbyt/pixlet/blob/main/examples/hello_world.star works fine, as per my previous post.

If you run pixlet render hello_world.star instead of pixlet serve --watch hello_world.star you may get better diagnostic messages.

I just use:

pixlet serve /home/alex/test.star

Then visit the local host link and if your file has no errors it should work

ah yeh the render command indicts that it “failed to load applet: starlark.ExecFile”
Any ideas please?

The problem is on line 7 of your file, where there’s a < that is unexpected. Can’t really tell more from that screen capture.

1 Like

Thank you! Yes very interesting, for the example .star files I right-click in Github and just download…but it comes out like this:

So I think in guide we need to state to copy the text and paste into a new file, do not download .star file from Github.
Now I’ve got the code in there it works:
image

Ahhhhh I see,

I’ll be sure to clarify that point!

Glad it’s all working though

1 Like

I’d like to run Pixlet on a BeagleBone Black, so I’d need a 32bit ARM binary. Has anyone successfully built it that way? Before I go down that path, I thought I’d ask. (32bit ARM could useful for older Raspberry Pi-based servers too.)

Just wanted to say thank you! I followed all the steps and just reached hello world! For some reason wsl was having internet connectivity issues - that is what ended up taking me the longest. Is there a way to view pixlet programs directly in Visual studio and not on local host?

2 Likes

Hi @gordon

While I can’t speak to the specifics of the BeagleBone Black or it’s OS, I am using a Pixlet built from source on my Pi 4 running PiOS which is 32-bit. Maybe my instructions may help you in your quest to get a version that works on the BeagleBone :slight_smile:

@drudge Thank you thank you! Very clear instructions, I think those will set me on the right path. Much appreciated.

figured out that you can view webp files in Visual Studio - so that solves my question

Glad everything is working for you! Feel free to join discord and ask any other questions. We got alot of friendly knowledgeable people there!

Hey @AmillionAir - again thanks so much for the tutorial would not have been able to install pixlet without it. One other small edit, your tutorial points to version 0.9.0 in step three (https://github.com/tidbyt/pixlet/releases/tag/v0.9.0). Might be better to point them too the releases page (https://github.com/tidbyt/pixlet/releases) so they install the latest version. Again thanks so much!

2 Likes