Can't install apps, is it that bad? maybe I need firmware upgrade?


Just received my tidbit, turned on, trying to install apps - in the app store about half of apps have spinner in place of preview that won’t go away.

Then I try to install. Only first app installed right away and show up on device. After that, install and the button and screen becomes unresponsive. Sometimes nt even scrolling works. Sometimes App page is responsive but nothing happens. Sometimes you can go back and go into another app and same thing. You can to to device screen and see that none of the apps you installed appear there. Then 15 min later one of them appears!

Yes, my internet connection is fine, never having any issues otherwise. No proxy or firewall.

And yes, I tried to reset the unit - same thing after reset. is there an upgrade I need to do ? can’t find the place.

It feels like the “Store” > “App” page is written in single thread where any operation blocks UI until it completes. And it was tested only in with perfect and fast connection so the issue never appeared.

I haven’t heard of the app behaving that badly before. Is it an old phone maybe ? The firmware on the tidbyt itself will automatically update but the firmware should have no effect on the phone app.

As a workaround you can try out my tidbyt manager web app that takes the place of the phone app. It’s still in beta so not a permanent replacement but you can at least test out different apps you might want to use.

And yes I know it is not https but it’s not like you’re entering your bank account on there :slight_smile:

That’s definitely very strange. I’ll see if we can reproduce this issue.

Yet another option is the web version of the Tidbyt app. This is very much an early release and not officially supported, but you can try it out at:

1 Like

Oh wow that’s amazing.

Yeah very much not ready for primetime, but it’s there if you want to try it.

1 Like

That’s exactly what I have requested. Great work!


I am using iPhone 13, no issues with any other apps or network connections.

After using for few more days, here’s my experience:

  • I have 4 apps installed.
  • go to apps store and add regular official Clock app, the one with badge.
  • App configuration screen opens. On this screen it’s frozen. can not scroll up and down or change any options.
  • If this is the first time I am adding such widget, the preview shows loading spinner. Otherwise it shows live app working in preview.
  • The only thing that responds to touch is “<” back arrow.
  • I select back arrow and apps list opens. some time later the app I selected to install may pops into “installed apps” screen.
  • Couple of times the app appeared 10 minutes later, after I used the app, left and opened it again.
  • Sometimes the app configuration screen un-freezes after few seconds. I can click Save button below and it may appear as expected.
  • Same freezing thing happens when I edit app that is already added, it opens to frozen screen.

This may be a silly basic question, but have you tried running Tidbyt app with link/connection profiler, ( like one in chrome development tools)? That will emulate a slow connection.

From UX point of view, on slow connection user would understand it working slower, but not locking up and freezing.

I got new issue happening randomly. The saved settings revert. In settings I disabled “Dim” and night more to see apps. It became bright and started to show apps. Exited settings screen and switched to other app.

When I came back to the room 5 minutes later, it’s in Dim/Night mode! I open the app and all changes I made in Settings are reversed! Tried again, issue did not happen again so far.

Yeah… this shouldn’t happen. We’re working on figuring out why it is happening, perhaps due to some recent new features and changes.

I am experiencing the same issue. The app on phone isn’t loading at all or extremely slowly. Once or if they do load you cannot add new apps to the tidbyt. It just spins. Any solution?