Can not get device to reconnect

Last night everything was fine. Woke up this morning and the display was stuck at 6:09 am. Tried to power cycle didn’t help pressed the blue button and now can’t get the decisive to connect at all. Tried removing and re-adding and can not get it to connect. Just says something went wrong. Any help would be greatly appreciated.

Got it working! Just took a couple tries of signing out and back in.

Hey there - so sorry @TroyRubert our services were experiencing an outage during this time and we are fully recovered now:

We’re going to make several changes to ensure an outage with this cause doesn’t happen agin.

I feel like I’m having a similar issue - when I first got the Tidbyt and set it up in my apartment a few months ago, it worked perfectly the first time.

I recently moved, got a new Wifi set up, and it won’t connect, it won’t even identify a Tidbyt on the network.

Hey Evan,

Sorry to hear this. I’ll reach out by email to help get to the bottom of it.