Is Pixlet only available on MacOS and Linux?

I had the same question, and disappointed I just now found this after trying to work around stuff for the last 5+ hours. I wish there was a streamlined way for Windows users – I was really looking forward to making some super personalized screens and maybe stuff like Twitch go live notifications, but unfortunately all of this finagling for Windows users just isn’t worth it to me.

1 Like

Going the Windows WSL and VScode route as suggested by
@jeremy wasn’t as much of a hassle as I expected it to be once I got my files in the right location.

@jeremy or @pineapple Would you mind outlining the steps you took in a bit more detail?

I was able to grab an old laptop from a family member that I’d live to just strictly use for development purposes. Right now I’m using @Scottorama method on my personal pc.

So I think I did the following steps to get it to work.

1.Download wsl using the install instructions found here.
2. Install VSCode and installed the Remote Development extension there. (I don’t know how much this is really required, but I did it anyway). You will be able to call the Ubuntu terminal through VSCode or through the Ubuntu app (just a terminal when you search it in the task bar).
3. Download the pixlet binary file into the bin folder of the Ubuntu (in windows file folder this is \\wsl$\Ubuntu\usr\bin).
4. While in the bin folder from the Ubuntu command line using sudo tar -xf <filename> where filename is the pixlet binary.
5. From here you should be able to download the zipped source file from github to get the examples (place this somewhere where you have write access on the Ubuntu side). ‘Ubuntu/home’ should work. It may be easier to download on the windows side and then unzip it to the remote side.
6. The examples outlined on github should now work.

Hope this helps!

Edit: fixed formatting and few clarifications.

Thanks @pineapple!

Ill be picking up the laptop from my brother in the next week or so. Ill give these steps a go and let you know if I have any issues!

Looking forward to being able to create stuff for my Tydbit

On slight question on point number 3 and 4 though.

Which of the files in github is the binary file? I’m not super familiar with what that is?


The pixlet_0.7.0_linux_amd64.tar.gz file.

1 Like

Thanks @pineapple and @Scottorama for the great start here-

I’m working to follow the directions to get pixlet working on my windows machine, but I’m encountering an error when I try to run the sudo tar -xf where filename is the pixlet binary. I am supposed to type the command as sudo tar -xf , right?

I’m getting an error that says -bash: syntax error near unexpected token `newline’

I’m doing a lot of googling, but Linux and coding in general is new to me.

@rohan, Would there be a more user-friendly method for windows coming out in the future?

Thanks all- and Happy New Year!

@Keith_Leonhardt woops, looks like I forgot a step. After
the sudo tar -xf step, run the following command (assuming you are in the bin folder).

sudo chmod +x /usr/bin/pixlet.

Then pixlet command and examples should work.

Edit: To answer your initial question, yes the full command I used was this.
sudo tar -xf pixlet_0.7.0_linux_amd64.tar.gz

Sorry @Keith_Leonhardt - I’ve not been checking in over the festive season. Did @pineapple get your issues solved? Once you have it up and running from VS Code with the remote WSL plugin, you probably won’t ever need to go into Linux unless something breaks :slight_smile:

Hey guys,

any idea what i need to do to get Step #4 to work here i keep getting this same error? Im not sure if this is useful info, but I have and intel processor. Should i be using the arm binary file instead of amd?

I’m not sure why it’s saying you can’t open the file or directory unless you aren’t in the folder that you put that .tar.gz file in, which would do it.

I was able to download the .gz file and unpack it just fine using that command. If you go to that file and right click the .tar.gz file from github and copy the link address and run
sudo curl -O -L <copied link address> and then do sudo tar -xf pixlet_0.8.5_linux_amd64.tar.gz that should work for this step.

However I haven’t been able to get pixlet to work past 0.8.2 as I may be missing a library or something. I opened up a github request though concerning that while I troubleshoot as my roommate is getting the same error.

If you get 0.8.5 to work let me know though!

hope this helps!

@AmillionAir ignore my comment about 0.8.5 not working I was actually just missing a library.

I’m not sure why it’s saying you can’t open the file or directory unless you aren’t in the folder that you put that .tar.gz file in, which would do it.

This might be where my problem lies im just launching unbuntu and then typing that sudo tar -xf command is there a specific way i need to access my bin folder within Unbuntu before i type that sudo tar -xf in.

Also, i really appreciate the help ive never used Linux so that is all an exciting learning experience for me!

@pineapple So after a few hours of googling i found that your 'Home" folder in linux is essentially where all of your downloads go. And lo and behold there are the tar.gz files and the extracted pixliet binary correct?


Am i able to just copy paste that pixlet file into my bin and continue on? I know linux is supposed to be a command line thing, but i should just to able to do that right?

@AmillionAir It’s been a few years since I’ve used linux, so I’ve been a bit rusty. But to answer your question as long as the pixlet file ends up in your bin folder you should be fine, so yes you should be able to just move it. You may have to sudo mv though. You know you should be set if you render one of their examples and it doesn’t error out. You should only need to move the pixlet file too as you can remove the .tar.gz file if desired.

From that screenshot though it looks like you got the binary unpacked and everything though.

@pineapple were so close I know it!

So i just did a simple copy/paste of the pixlet file into my bin and then tried to run things the hello world example file and got a permission denied error. then i remembered i needed to run the sudo chmod +x /usr/bin/pixlet. to make sure i had proper access to the pixlet file

Now if i try to run the example again i keep getting an error that i dont have a certain file or directory installed?

is this something additional i need to download?

Also on a side note once i get this figured out im going to make a full dum dum list of all the steps i took and post it for anyone who needs it.

@AmillionAir I had the same issue. The stuff in the issue I opened and solved should fix it. See the link Here

I’m on mobile so sorry if formatting is off.

You may have to update other libraries too, but this should fix that error.

At this point I’ve done this so many times you’re going to have it memorized by the end ha ha, but having one solid post isn’t a bad idea.

1 Like


@pineapple I am so thankful you went above and beyond to help a random idiot on the internet figure out how the hell to use Linux.

I guess the last question for any of you guys @pineapple or @jeremy is how do i start using VS Code to make stuff? is there a specific thing i need to point VS code to or is it just as simple as open up one of the example files in VS code and go to town??? Good news is i actually know how to code in python so this is pretty much the last step for me.

1 Like

I’ll type a full reply this weekend - but if you navigate to the directory in WSLwhere you checked out your code and enter “code .” It should launch VSCode with a terminal scoped to your current directory in WSL.

You can then run commands in the built in terminal in VS Code (assuming pixlet is on your path).